Audacity y el problema con las librerias FFMPEG y Gstreamer en Ubuntu 14.04(y similares):Como Solucionarlo.



Hola de Nueva cuenta,los saluda Pegasus BTX.

Cuando uno usa un sistema gratuito y libre(hasta cierto punto) como linux,siempre habra algo que hacer ,aprender y resolver alguna falla que pueda tener...el dia de hoy,hablaremos de eso.

Comunmente como AudiofiloMelomano,me gusta ir a comprar vinilos,ya sea en los tianguis,tiendas de antiguedades,escaparates y por internet,y soy de esa clase de gente bendecida que tiene un padre que fue discotecario y tiene varias tornamesas para diferentes propositos,asi que suelo usar una tornamesa profesional para pasar el sonido analogico de un LP u disco de 45 rpm,a un formato digital(comunmente OGG para mi reproductor y FLAC para el centro de sonido u el mismo tornamesa pegado al centro de sonido si quiero ponerme "romantico")...


y desde que he usado ubuntu y distros derivadas de ella como linuxmint,zorin,entre otras,siempre use el programa Audacity por default para llevar tal conversion,obteniendo resultados excelentes...hasta que llego la nueva version de ubuntu..la 14.04 u como es conocido entre los freaks"el chivo cojelon" u como le digo de cariño asesino..."La puta de la Kabra"...

resulta ser que cuando le instalo el audacity para seguir trabajando en mi vicio musical....me encuentro con la sorpresa que del tornamesa no entra nada...NADA!!...ni un sonido,ni una miga sonora...me puse a revisar el ALSA y no reconocia nada de entrada ni de grabacion... entonces cheque en las preferencias de audacity...y me encuentro con la pesadilla...


Lo que ocurrio es que los muy cabezasduras de Canonical(y me imagino que Debian tambien,aunque no es muy seguro),decidieron mandar por el tolete el FFMpeg,con todo y Gstreamer,que son las librerias que hacen que muchos programas de audio y video funcionen como debe ser(VLC es cosa aparte)eso incluye la captura de video y audio en vivo...y todo para incluir un nuevo pack de codecs llamado LIBAV...por esa razon,programas como parole,exaile,u alguno que depende de FFMPEG y Gstreamer,simplemente no funcionan correctamente y te mandan errores que "necesitan de las dependencias para funcionar"

pero no te preocupes,que hay una solucion para todas esas cosas..siempre de la mano de nuestra querida amigocha "la terminal"..

1-.Instalar Ubuntu restricted Extras
es un pack de codecs que comunmente no maneja Ubuntu de forma Nativa,y que en muchos paises no son "legales",como el mp3,acc,wma,mpeg entre otros mas.

Para instalarlo abrir una terminal y copiar este comando:

sudo apt-get install ubuntu-restricted-extras
y darle enter y que haga su trabajo...


2-.Instalar LIBAVCodec "No restrictivo"

Este es el weon que hace que si instalas el ffmpeg desde la pagina oficial u otros codecs simplemente no funcionen,asi que instalaremos y remplazaremos la version de canonical,por la version "no reestrictiva"que es adaptable y se complementa con los codecs ya instalados.
para instalarlo,en la misma terminal copear este comando:

sudo apt-get install libavcodec-extra
Darle Enter y esperar a que reemplace todo el mierdero que canonical puso...


3-.Instalar el PPA de FFMPEG y Gstreamer 0.10 PPA

La cereza del pastel es este complemento que le ha dado mas de uno severos dolores de cabeza,ya que sin el...no puede tu reproductor leer los dvds correctamente,no puedes grabar en vivo en H.264,ni ver correctamente el HTML5 en firefox,entre otras linduras...

Para instalarlo solo copea estos comandos,de uno por uno:

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install gstreamer0.10-ffmpeg
Despues de instalar todo,solo nos queda reiniciar el sistema para que los cambios se queden como estan ahora..

Los Resultados saltan a la vista:







 Notas Importantes a tener en cuenta:

A)Los formatos varean segun el programa,por conversores de audio y video,no tendran problemas,capturadores de video y audio,checar segun el programa que esten usando.

B)Los comandos solo sirven para la version de Ubuntu 14.04 y sus derivadas(Kubuntu,Xubuntu,Lubuntu,edubuntu,Ubuntu Studio...etc) y Linux Mint u cualquier distro basada en esta version LTS.


 espero que este tutorial le haya salvado la vida a mas de uno...a mi me la salvo y por eso la comparto con ustedes.

saludos y se despide:







Comentarios

Entradas populares